With OpenWrt 21.02 and DSA configuration, the 'lan' interface is now divided into a bridge called 'br-lan' and an interface called 'lan'. You now use 4 'list ports' lines instead of 1 'ifname'. The wan interface changes from 'ifname' to 'device' config device option name 'br-lan' option type 'bridge' list ports 'eth0' list ports 'eth1' list ports 'eth2' list ports 'eth3' config interface 'lan' option proto 'static' option ipaddr '192.168.1.1' option netmask '255.255.255.0' option ip6assign '60' option device 'br-lan' config interface 'wan' option device 'eth4' option proto 'dhcp'
After watching tons of videos about basic configuration, finally I have found Yours which clearly explains how to configure in x86 wan and lan interfaces. Everything is working flowesly now
Vey well donde, Would have been nice if you showed the possiblities of more powerful hardware with various test cases to trully see what people could be missing out.
Hello Van...this video is super charm with my old pc. Beside can you make a video about "how to choice part ethernet" which openwrt has supported, like your ethernet pcie card you have used in video . I just figure out one way that find out the SOC controller of that part and searching on openwrt package database. Thank you so much
Great video. I am planning on building my very own router with LTE modem functionality. I see some PCIE modules on Aliexpress that have sim trays. Is this going to be possible and do you have a video on this? Thanks in advance.
Hello Sir, I love your OpenWrt videos. Thank you for making them for us. Can you please make a video on Geo-IP blocking with OpenWrt. Also, are those purple LAN cables CAT6, CAT6A or CAT7??
Hi, can you plewse help with network configuration for openwrt on oracle virtual machine? I ve installed all the software and stuff, but cant get it working as a router with PPPOE on motherboard NIC and lan port trough a usb network adapter. Thank you
Hello Van, I am relatively new to routing. I had read somewhere that it's better to not use the built-in network port and instead have everything on the NIC. So have the WAN and LANs all on the 4 ports of the NIC. Supposedly this is better for performance. Idk if this is true or not but can u verify or clarify that?
Hello Van. Is it possible you can do a video on how to setup Intrusion Prevention System in an OpenWRT system. Specifically setup for IPS and not just IDS. Thank you. I can't find any good tutorials.
hey good day i installed XCP-Ng on my Dell Desktop and when im running a VM the Link Status Keep Disconnecting. do you Guys known how i can fix this problem please
Hi, the TDP for L5630 is 40W, which is very low power consumption compare to other vintage/legacy Xeon. In the recent 10G OpenWRT build, the Xeon E3-1230v2 with the 10G SFP+ adapter & ethernet adapters only consumes 28W during idle, you can check out here ua-cam.com/video/6sfs6tvDkg4/v-deo.html
Hi Syed, with this installation method, the OS and configuration is stored on the USB drive. It will be store safely after shutdown. However, if you want to install OpenWRT to the HDD, you can follow this video ua-cam.com/video/cOLn2H1FZEI/v-deo.html
With x86, each network port can only carry 1 tagged VLAN ID (if you are about to connect the network adapter to the AP). If you need to configure multiple vlan, please try a router or using a smartswitch/L2 switch with x86. There are some videos related to VLAN PPPoE where you can find tutorial for VLAN creation on OpenWRT.
With OpenWrt 21.02 and DSA configuration, the 'lan' interface is now divided into a bridge called 'br-lan' and an interface called 'lan'. You now use 4 'list ports' lines instead of 1 'ifname'. The wan interface changes from 'ifname' to 'device'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
list ports 'eth1'
list ports 'eth2'
list ports 'eth3'
config interface 'lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option device 'br-lan'
config interface 'wan'
option device 'eth4'
option proto 'dhcp'
Thank you for the information. I have pinned this and hope that it will help others.
After watching tons of videos about basic configuration, finally I have found Yours which clearly explains how to configure in x86 wan and lan interfaces. Everything is working flowesly now
Good video. Liked the bridge method. Good informative. Thanks!
Glad you enjoyed it! There are othet tutorials on the channel, feel free to check it out ua-cam.com/play/PL58__w3t_eTbcBQ9oJ8jXCxPtBiac59vC.html
this helped me out huge, thank you
you can also ping 1.1 it will automatically replace it with 1.0.0.1 which also works
Great, thanks for sharing this.
Vey well donde, Would have been nice if you showed the possiblities of more powerful hardware with various test cases to trully see what people could be missing out.
Hello Van...this video is super charm with my old pc. Beside can you make a video about "how to choice part ethernet" which openwrt has supported, like your ethernet pcie card you have used in video . I just figure out one way that find out the SOC controller of that part and searching on openwrt package database. Thank you so much
Great video. I am planning on building my very own router with LTE modem functionality. I see some PCIE modules on Aliexpress that have sim trays. Is this going to be possible and do you have a video on this? Thanks in advance.
Hello Sir, I love your OpenWrt videos. Thank you for making them for us. Can you please make a video on Geo-IP blocking with OpenWrt. Also, are those purple LAN cables CAT6, CAT6A or CAT7??
Thanks for the comment, I will put the Geo-IP blocking in the to-do videos list. The purple cable is CAT7 from Vention.
Network Card Driver issue....can you please help me to understand the step by step to install driver in x86 openwrt...
Hello bro
After updated to OpenWRT 22 X86, I can't access through LuCi web interface, ifconfig show Loopback interface only, how to solve the problem?
Hi, can you plewse help with network configuration for openwrt on oracle virtual machine? I ve installed all the software and stuff, but cant get it working as a router with PPPOE on motherboard NIC and lan port trough a usb network adapter. Thank you
Thank you!
You're welcome!
Hello Van, I am relatively new to routing. I had read somewhere that it's better to not use the built-in network port and instead have everything on the NIC. So have the WAN and LANs all on the 4 ports of the NIC. Supposedly this is better for performance. Idk if this is true or not but can u verify or clarify that?
Hello Van. Is it possible you can do a video on how to setup Intrusion Prevention System in an OpenWRT system. Specifically setup for IPS and not just IDS. Thank you. I can't find any good tutorials.
Hello great great video.. i am wondering if OpenWRT have support for Fiber 100Gbps network adapters.
It depends on the Network Adapter you are using. So far I only tested with 10Gbps. You can find those videos on the channel.
wow !!! so good !!!
Glad you like it!
so are you using this instead of original modem?
192 168 1 1 gives the modem interface please answer,
hey good day i installed XCP-Ng on my Dell Desktop and when im running a VM the Link Status Keep Disconnecting. do you Guys known how i can fix this problem please
I wonder how much watts realtime when old Xeon processor full load and idle state running openwrt x86
Hi, the TDP for L5630 is 40W, which is very low power consumption compare to other vintage/legacy Xeon. In the recent 10G OpenWRT build, the Xeon E3-1230v2 with the 10G SFP+ adapter & ethernet adapters only consumes 28W during idle, you can check out here ua-cam.com/video/6sfs6tvDkg4/v-deo.html
Hi Van , will the configuration safely kept inside the flash drive anytime we reboot the machine ?
Hi Syed, with this installation method, the OS and configuration is stored on the USB drive. It will be store safely after shutdown. However, if you want to install OpenWRT to the HDD, you can follow this video ua-cam.com/video/cOLn2H1FZEI/v-deo.html
@@VanTechCorner Thank you for being very helpful
👍👍 thank you.
Thank you too!
I have 1 x86 openwrt as router and multiple openwrt as AP (daisy chained). How do I setup multiple vlan for multiple ssid?
With x86, each network port can only carry 1 tagged VLAN ID (if you are about to connect the network adapter to the AP). If you need to configure multiple vlan, please try a router or using a smartswitch/L2 switch with x86. There are some videos related to VLAN PPPoE where you can find tutorial for VLAN creation on OpenWRT.
Whats the power consumption on this setup?
can we Config Multiwan on this?
Teach us how to do link aggregation in openwrt
Would be a good alternative if you rather use opnsense.
Hey, thanks for the comment. For the time being, most of my tutorials are for OpenWRT, maybe pfSense/OPNSense in the future time.
I just switched from OPNsense to OpenWrt, as my WiFi card was not supported in *BSD.
hallo, i want to ask
why everytime i reboot my x86 openwrt its not automatically turn on again? it just stuck
thanks
Hi, you need to configure this "what the PC will do after power restored" in your BIOS.
hi friend, anyway to host/create virtual machines inside openwrt box?
Hi, normally people will revert the step. They will install vmware esxi and then create VM for Openwrt and other application/OS.
yes your right, well i am looking for somethin that can handle ecerything out of box.... Thank You so much and good videos
how openwrt mi4 a gigabit for windows method?
Hi, you can find the installation guide here openwrt.org/inbox/toh/xiaomi/xiaomi_mi_router_4a_gigabit_edition
@@VanTechCorner this tutorial not work