MikroTik Dual WAN over 2 DHCP Internet Connections

Поділитися
Вставка
  • Опубліковано 7 лис 2024

КОМЕНТАРІ • 335

  • @zbgslavi
    @zbgslavi 3 роки тому +5

    The scripts will not work correctly, if the DHCP server just change the gateway. It will go to the :error "Multiple routes found'. I suggest better script. When you apply it to the WAN2 DHCP client, just change the first line.
    {
    :local rmark "to_wan1"
    :if ($bound=1) do={
    :if ([/ip route print count-only where comment=$rmark] = 0) do={
    /ip route add distance=1 gateway=$"gateway-address" check-gateway=ping routing-mark=$rmark comment=$rmark
    /ip route add distance=1 gateway=$"gateway-address" check-gateway=ping comment=$rmark
    } else={
    :foreach r in=[/ip route find where comment=$rmark] do={
    :if ([/ip route get $r gateway] != $"gateway-address") do={
    /ip route set $r gateway=$"gateway-address"
    }
    }
    }
    } else={
    /ip route remove [find comment=$rmark]
    }
    }

  • @matthewfranck5458
    @matthewfranck5458 4 роки тому +1

    This is amazing!! Thank you so much for this!!

  • @Elrevisor2k
    @Elrevisor2k 3 роки тому +1

    thanks for sharing if I want also do this for wireless what I need to do as I see only one port Lan is enabled but for the 2g and 5g wireless to happen what I need to do?

    • @wifilabxyz
      @wifilabxyz  3 роки тому +1

      create a bridge, make this bridge as your LAN. add wifi and port interfaces to it.

  • @joelram3182
    @joelram3182 4 роки тому

    i tried the dual wan static and it was perfect.. thank you for that also

  • @metalstream
    @metalstream 4 роки тому +3

    Great tutorial bro, still i dont get why we must send you an email for the scripts when you can just copy&paste on the description...

    • @wifilabxyz
      @wifilabxyz  4 роки тому +2

      It's in the description...

  • @jean-francoishetu6147
    @jean-francoishetu6147 9 місяців тому

    Could you confirm my understanding... if we don't complete the configuration with the mangle rules and simply keep the DHCP client configuration. Then this becomes a simple Dual WAN DHCP client failover solution?
    ie: the mangle portion allows for load balancing, correct?

  • @jez1357
    @jez1357 4 роки тому +1

    ito ung pinaka clear tuts.... sir baka full scrip ka sir baka pwde maki share

    • @wifilabxyz
      @wifilabxyz  4 роки тому

      It's in the description...

  • @dexturevlogs5677
    @dexturevlogs5677 2 роки тому

    Hello, I hope i can receive a response for this. I used this configuration and its work totally fine for my dual wan set-up, however, i can't ping to the networks i created on LAN3 and LAN4 vice versa. Given the fact that, that LAN1 AND LAN2 is for ISP. Any suggestion how my networks could ping each other.

  • @mikey_2387
    @mikey_2387 3 роки тому +1

    Is it possibleto have 3 isp. 2 isp is for bonding/browsing and the other one is for gaming purposes only?

  • @wncgcg
    @wncgcg 2 роки тому +1

    @wifiLAB, excuse my ignorance, but where should i paste the script provided? I'm a newbie!!!

    • @wifilabxyz
      @wifilabxyz  2 роки тому +1

      from the terminal...

    • @wncgcg
      @wncgcg 2 роки тому +1

      @@wifilabxyz thanks so much for replying back at me!!

  • @ilyasft9640
    @ilyasft9640 3 роки тому

    Thank you for this video!
    i'm successfully join both my WAN connection.
    if i can ask 1 question, how do i force certain IP Address/client to use only WAN1 ?
    i tried using source address != "Block to WAN2" but the client still using both WAN connection

  • @kscius
    @kscius 3 роки тому +1

    I used Bridge to share the DHCP Server to ether3 and ether4 (3 for WLAN and 4 for LAN)

  • @commandertako
    @commandertako 2 місяці тому

    what to do if the router has bound to ISP1 is still active but has no internet are there a way to reroute the connection to ISP2? Ive try everything but the connection will be disconnected to and need to cut the connection of isp 1 just to transfer the route to ISP2

  • @arodb86
    @arodb86 3 роки тому

    Hello, what should I do in order to activate WLAN ( WIFI) using the same Balanced LAN..??? Thanks

  • @sohrkim
    @sohrkim 3 роки тому +1

    impressive!

  • @BenzkyG101
    @BenzkyG101 3 роки тому +1

    Is this merging dual isp boss?

    • @wifilabxyz
      @wifilabxyz  3 роки тому

      nope, it just balances the traffic from 2 different ISPs.

  • @jvsbm
    @jvsbm 2 роки тому

    Parabéns e muito obrigado top da mais

  • @jez1357
    @jez1357 4 роки тому +1

    maraming salamat sir ung config nito ung gusto talga salamat sir

  • @kscius
    @kscius 3 роки тому +1

    the scripts has some extra characters from the parser, should be like this
    {
    :local rmark "to_wan2"
    :local count [/ip route print count-only where comment="to_wan2"]
    :if ($bound=1) do={
    :if ($count = 0) do={
    /ip route add distance=1 gateway=$"gateway-address" check-gateway=ping routing-mark=to_wan2 comment="to_wan2"
    /ip route add distance=1 gateway=$"gateway-address" check-gateway=ping comment="to_wan2"
    } else={
    :if ($count = 1) do={
    :local test [/ip route find where comment="to_wan2"]
    :if ([/ip route get $test gateway] != $"gateway-address") do={
    /ip route set $test gateway=$"gateway-address"
    }
    } else={
    :error "Multiple routes found"
    }
    }
    } else={
    /ip route remove [find comment="to_wan2"]
    }
    }
    only changes wan2 for wan1, the logic of the script are the same

    • @lucianodisarno4328
      @lucianodisarno4328 2 роки тому

      There is an error here i believe... The second ip route should add a distance = 2...

  • @lightbeam6783
    @lightbeam6783 3 роки тому +1

    Hello there. I have followed the instructions on this video to the T and i'm not getting internet breakout on the mikrotik when the wan is connected to either wan1 or wan 2 - getting no route to host error? Please can you give more information on the ip/route setup?

    • @wifilabxyz
      @wifilabxyz  3 роки тому

      maybe u have missed something. please try the script posted in the description.

    • @lightbeam6783
      @lightbeam6783 3 роки тому +1

      @@wifilabxyz Thank you so much for the reply. I started everything form scratch and it is now working just as it should. You are probably right , my bad :)

  • @wilsonjuance3760
    @wilsonjuance3760 4 роки тому +2

    Sna next po 2 mikrotik nmn
    Mt 1 multi isp.
    Mt 2 . Bandwidth mgmt , hs and ppoe

  • @EraseAllDrives
    @EraseAllDrives 2 роки тому

    @wifiLAB, hello, how to make your script work with l2tp providers?

  • @badburn
    @badburn 3 роки тому +1

    nice tutorial. Sir, saan po galing yung 192.168.1.1 at 192.168.2.1 na gateway? thanks

    • @wifilabxyz
      @wifilabxyz  3 роки тому +1

      yan po ung dalawang router na nakakonek sa mikrotik. 1 isp router = 1.1 at 2 isp router = 2.1

    • @badburn
      @badburn 3 роки тому

      @@wifilabxyz Thank you Sir. Did copy and pasted the script on the Mikrotik terminal. The mikrotik router can ping google.com via terminal but the laptop can't ping google.com. will check again.

  • @TechnicalMamunBengali
    @TechnicalMamunBengali 3 роки тому

    (ether1=pppoe-client)+(ovpn -client/l2tp-client/sstp-client/pptp-client) = (ether 2=dhcp)
    where vpn connection will only be used for block site to open.
    bro how can i do that??
    i need your help .

  • @psywareSSL
    @psywareSSL Рік тому

    Thanx for the tutorial but does not work on any of my MTK´s in 7.11 router OS...could u send me the scripts to my mail?
    best regards

  • @3l_96
    @3l_96 3 роки тому

    Thank you bro 😎

  • @ZindelLeander
    @ZindelLeander 3 роки тому +1

    Boss pwede ba ito kung pareho PLDT Home Fibr yung ISP1 and ISP2 ko?

  • @waldenlaab4285
    @waldenlaab4285 3 роки тому

    Sir what will happened when two isp dhcp meet in load banlancer ?
    And meet static and dhcp in load banlancer?

  • @TechnicalMamunBengali
    @TechnicalMamunBengali 3 роки тому

    or a list of websites will be passing through over vpn while user hit these websites

  • @rk12450
    @rk12450 3 роки тому

    Dear Team,
    Pls help me for This rules is i ussing
    But the banking site reirect not not login issue

  • @enoypinedo6274
    @enoypinedo6274 3 роки тому

    muchas gracias... estoy usando dos WAN de 10M, está funcionando muy bien... estoy usando Bridge, y detalles en IP Routes..

    • @kscius
      @kscius 3 роки тому

      fijate que yo tambien tuve que usar Bridge para repartir el DHCP Server entre ether3 y 4

    • @cristianbarboza6298
      @cristianbarboza6298 2 роки тому

      consulta: Te sumo los 2 enlaces? porque yo no logro hacerlo

  • @ArcTour292
    @ArcTour292 4 роки тому +2

    Thank you for this video. I've been seeking for solution setting up mikrotik with 2 WAN both DHCP-client. Your script is good, but I think there is some mistake in it - in section :if (count=1) we need to write count=2, 'cause we recently created 2 routes in upper section. But I may be wrong. Best regards!

    • @tradethatask7518
      @tradethatask7518 4 роки тому

      Did you get a reply back on this. I can't get it to auto create the comments and default route using the script.

    • @wifilabxyz
      @wifilabxyz  4 роки тому

      It's in the description...

  • @baradotvfunents4979
    @baradotvfunents4979 4 роки тому +1

    thanks

  • @bulitobayagbag6683
    @bulitobayagbag6683 4 роки тому

    sir how to create packet marks using this routing setup po?
    di ko kasi mapagana yung sakin pwede po pa turo kahit isang set of mangle lang. example is Streaming. how can I create packet marks para magamit po sa Q3
    Thanks sir.

  • @jez1357
    @jez1357 4 роки тому

    advance tanks sir

  • @salemoraya1398
    @salemoraya1398 4 роки тому +1

    thanks..

  • @calotcalot
    @calotcalot 3 роки тому +1

    Hi sir is there any chance that we cna check ping 8.8.8.8? Since most outages WAN gateway(ISP modem) is still reacheable unless it its hardware/power related. Thank you. This is very helpful

    • @wifilabxyz
      @wifilabxyz  3 роки тому

      u can try netwatch or recursive route (i think i have this in 3WAN static video)

  • @Alescaramanzia
    @Alescaramanzia 2 роки тому

    Thanks a lot, this works!!!

  • @raivillegas7242
    @raivillegas7242 4 роки тому

    Sir from this set up then saksak ko to to another MT na may confi for pisowifi swak ba to?

  • @cristianbarboza6298
    @cristianbarboza6298 2 роки тому

    Como puedo hacer para que sume los 2 anchos de banda??

  • @nachorepara
    @nachorepara 2 роки тому

    hi! great video! but, i cannot make to work the script, when i create the dhcp-client and put the script, it doesn`t create the statics routes. I put it excactly like the description on your video, copy-paste in the terminal, but wont work. I do some modifications to it, but same results, it take some IP from my ISP but nothing happend on the statics routes. Maybe it is wrong? Is ther a way to debug it? Thnks for your help!

    • @tekniqal2639
      @tekniqal2639 2 роки тому

      Same here. Followed the tutorial to the letter but the default routes do not show up as shown in the video. I guess the maker of the video has moved on.

    • @nachorepara
      @nachorepara 2 роки тому

      @@tekniqal2639 hey! I resolved it downgrading My mktk to last versión 6 (i had versión 7) i supose script doesn't work in 7.

    • @tekniqal2639
      @tekniqal2639 2 роки тому

      @@nachorepara You know I thought of that but I was thinking of using the containers feature and it only only works with 7. No wireguard with 6 also. What is the latest version of 6 that can be used. Or at least, what version number are you using?

    • @nachorepara
      @nachorepara 2 роки тому

      I have now 6.48.6 ando it works fine! You should try it, or i think you must search some script for 7.x.x

    • @tekniqal2639
      @tekniqal2639 2 роки тому +1

      @@nachorepara Thanks dude. I did look at another guide (see here: ua-cam.com/video/IsJlBqpVgGo/v-deo.html). He is on 7 but I do not think it really works. He uses the main table and when I turn that off setup stops working which suggests the configuration is not really doing anything. Anyhow, thanks again.

  • @sanfrancamotes7530
    @sanfrancamotes7530 3 роки тому +1

    The configuration for MT rb4011?

  • @renzorioja1964
    @renzorioja1964 3 роки тому +1

    sir bkt parang nka limit lang po sa 30mbps ang wan2 ? thankyu sir

  • @johnrolansunido4626
    @johnrolansunido4626 4 роки тому

    Sir parang sa tutorial mo pag nakatangal lng yung cable ska ngfafailover pano kung nkasaksak pa din sa router tpos internet lng ang wala.

    • @wifilabxyz
      @wifilabxyz  4 роки тому

      gawa po kayo script para mamonitor ung internet connection or try netwatch.

  • @newtonmuuo1659
    @newtonmuuo1659 2 роки тому

    HI the script is not adding routes automatically kindly help

  • @norwhyndavesales3482
    @norwhyndavesales3482 3 роки тому +1

    ano main wan ip na gagamitin ng setup na to boss?

    • @wifilabxyz
      @wifilabxyz  3 роки тому

      main wan ip ng alin sir?

    • @norwhyndavesales3482
      @norwhyndavesales3482 3 роки тому +1

      yung public IP na gagamitin nia boss, sa ISP 1 ba or ISP 2. para sana sa ip whitelisting just incase.

    • @wifilabxyz
      @wifilabxyz  3 роки тому +1

      most of the time ung isp 1 sir.

  • @choitoi67
    @choitoi67 3 роки тому

    pwede ba to lagyan ng anti lag sir ?

  • @fearmtechwireless6145
    @fearmtechwireless6145 2 роки тому

    Hello Good day

  • @mehebubbinahmed1036
    @mehebubbinahmed1036 3 роки тому

    Please make a tutorial 1pppoe+1dhcp
    Load balancing and failover

  • @notsoordinary8731
    @notsoordinary8731 3 роки тому

    Paano if same 192.168.1.1 binibigay sa dhcp client

  • @akeemarcayera
    @akeemarcayera 3 роки тому

    Boss thank you!! Gumana yung code!!
    Tanong ko lang din sana if sang banda mag eedit if gusto ko iactivate yung dalawang ports plus yung wifi. Salamat ng marami! God bless!!

    • @wifilabxyz
      @wifilabxyz  3 роки тому

      gawa ka ng bridge, tapos add mo ung dalawang port at wireless dun sa ginawa mong bridge.

    • @thenomadtrade
      @thenomadtrade 3 роки тому

      @@wifilabxyz pwede ba kitang i add sa facebook sir?

    • @zwack2097
      @zwack2097 Рік тому

      ​@@wifilabxyz bakit po wlang kang ginawang bridge sa video?

  • @reparacionytecnologiaparat2582
    @reparacionytecnologiaparat2582 4 роки тому +1

    hola gran video podra apoyarme con los script
    saludos y gracias

    • @wifilabxyz
      @wifilabxyz  3 роки тому

      it's in the description...

  • @jenrichonlineshop1712
    @jenrichonlineshop1712 4 роки тому

    Ito bossing kailangan ko..salamat

  • @TechnicalMamunBengali
    @TechnicalMamunBengali 3 роки тому

    bro i have copied that dhcp code from your video by typing in notepad.

  • @redcat483
    @redcat483 4 роки тому

    Nice. Pwede po makahingi ng Script? Thanks

  • @tradethatask7518
    @tradethatask7518 4 роки тому

    I can't get it to auto create the "to_WAN1" comments under routes and also auto create the default route using the script and followed this closely. Any suggestions?

    • @tradethatask7518
      @tradethatask7518 4 роки тому

      I have an RB2011UiAS and version 6.43. I'm testing with a single ISP and when I connect, it creates the subnet route but not 0.0.0.0/0 default route and also does not insert the comment "to_wan1" etc. Any advice would be helpful to troubleshoot - jason@jakadas.com and jason.bawcom@gmail.com.

    • @tradethatask7518
      @tradethatask7518 4 роки тому

      Nevermind. I found the issue with a ")" vs. a "}" in one place. Once I addressed this, it worked fine. Thank you!

  • @FAST-TECH0101
    @FAST-TECH0101 4 роки тому

    please add 4wan dhcp configuration MikroTik

  • @BunalmananapTV
    @BunalmananapTV 3 роки тому +1

    Pa share nmn scrip sir

    • @wifilabxyz
      @wifilabxyz  3 роки тому

      nasa description ng video sir

  • @aotsimp4
    @aotsimp4 4 роки тому +1

    pa send din script for dhcp sir...
    dino.johnson05@gmail.com
    salamat at godbless!

  • @kaungmonsoe5020
    @kaungmonsoe5020 4 роки тому

    Please Can I get your Script..

    • @wifilabxyz
      @wifilabxyz  4 роки тому

      email?

    • @kaungmonsoe5020
      @kaungmonsoe5020 4 роки тому +1

      @@wifilabxyz kaungmonsoe9@gmail.com

    • @wifilabxyz
      @wifilabxyz  4 роки тому +1

      sent

    • @kaungmonsoe5020
      @kaungmonsoe5020 4 роки тому +2

      @@wifilabxyz I well received with thanks.

    • @lawrencegithui9543
      @lawrencegithui9543 3 роки тому

      @@kaungmonsoe5020 hallo brother can you help me with the scripts to my email lawrengits@gmail.com thanks in advance

  • @jez1357
    @jez1357 4 роки тому +1

    sir baka pwde na ako makahingi ng script nito cardinalajc19@gmail.com maraming salamat po sana mapansin nyo po ako

  • @dyyoung7573
    @dyyoung7573 4 роки тому +1

    Pa send din po script salamat po.
    dyyoung1028@gmail.com

  • @clydedrexler9431
    @clydedrexler9431 4 роки тому +1

    pasend din po ng script @ drexlerguapo12@gmail.com thank you po

  • @michaelmacandog4914
    @michaelmacandog4914 4 роки тому +1

    pa try po sir penge po ng script kenmichael05@gmail.com salamat po sir

  • @JyCny
    @JyCny 4 роки тому +1

    pa send po script newbie lang po salamat ^_^. canoyarnulfop@gmail.com

  • @warfaachannel2013
    @warfaachannel2013 3 роки тому

    Please help me bro

  • @paulpagcaliwangan5137
    @paulpagcaliwangan5137 4 роки тому +1

    pwede po makahingi script. paulpagcaliwangan@gmail.com salamat

  • @abelyap4666
    @abelyap4666 4 роки тому +1

    sir p send poh ng script kenkerby40@gmail.com

  • @pinoycoccoc4465
    @pinoycoccoc4465 4 роки тому +1

    pwede pa send ng script? Salamat po. pinoy1coc@gmail.com

  • @MrRenz15
    @MrRenz15 4 роки тому +1

    sir pa send po ng script brezr15@gmail.com thankyou po

  • @AlbertTafilaj
    @AlbertTafilaj 2 роки тому

    Anyone managed to get this working on OS 7.1?

  • @solrista664
    @solrista664 Рік тому

    pleasedo tutorial on dual wan + failover on mikrotik v7