SSH ON ASA

Поділитися
Вставка
  • Опубліковано 24 кві 2020
  • SSH ON ASA
    ! SSH can be configured on any Interface
    ! Let’s assign hostname and configure an IP address on ASA and R2
    Configure terminal
    Hostname ASA
    !
    interface GigabitEthernet0/0
    nameif INSIDE
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    no shutdown
    exit
    R2
    Enable
    Configure terminal
    Hostname R2
    !
    interface Ethernet0/0
    ip address 192.168.1.2 255.255.255.0
    no shutdown
    !
    Do ping 192.168.1.1
    --------------
    ! On ASA
    ! SSH requires username and password
    ! SSH requires domain name
    ! SSH requires cryto key to make the connection secure
    !
    ! Let's define the network from SSH connections will be initiated
    ssh 192.168.1.0 255.255.255.0 INSIDE
    ! Lets define domain nameif
    domain-name networkinginfo.in
    ! Lets generate a RSA key which is important
    crypto key generate rsa modulus 1024
    yes
    ! Lets create a username and password
    username Dinesh password cisco privilege 15
    ! Lets tell ASA to use local authentication for console and SSH
    aaa authentication ssh console LOCAL
    ! LOCAL keyword must be case sensitive
    ! Lets verify the SSH from R2
    On R2
    ssh -l Dinesh 192.168.1.1
    ! Let's verify ASA SSH Sessions
    show ssh
    show ssh session detail
    ! This is how we can configure SSH on any interface
    ! Thank you for watching and I hope you enjoyed.

КОМЕНТАРІ •